windows环境启动ElasticSearch报错:

1
2
exception caught on transport layer [Netty4TcpChannel{localAddress=/192.168.6.155:9300, remoteAddress=/192.168.6.155:54890, profile=default}], closing connection
java.lang.IllegalStateException: Received message from unsupported version: [6.2.3] minimal compatible version is: [6.8.0]

图片
原因:ES的jar包版本不符合要求,下载符合要求的jar包即可
这里直接通过IDEA中的maven进行下载,
![图片](https://ahzo.gitee.io/img/record/r10522.png
需要确保jar包下载的位置与环境变量里的maven配置文件中设置的仓库地址对应
图片
下载完成后重新启动ES

…….

结果还是报同样的错,一气之下把elasearch仓库里所有6.3.2版本的jar包全删了,再次启动
图片
成功

图片